Internet Explorer V6 and V7 support will be dropped later this year. This is due to the fact that vBulletin (our forum software) will drop support in the next major release (4.2).

NB: Internet Explorer V6 and V7 will not render the site correctly and you may find that you cannot post or see the site correctly using IE6/7 browsers.

These changes will make the technical support of PBB Forum much easier, site speed and efficiency will become better. It also encourages people to move to better/faster/safer browsers.

PBB Forum will officially support the following browsers on Windows, Mac and Linux ... (until advised otherwise)

  • Internet Explorer: stable releases 8+
  • Firefox: all major stable releases starting from 4+ (e.g. 4., 5., etc.)
  • Safari: 5+
  • Chrome: latest stable
  • Opera: latest stable


Microsoft stopped support for these and so are most internet firms which basically means in the next 12 months they will be rendered useless to browse the web. Some businesses, schools etc are still using it on their networks, not only are they putting them selves at risk but they are putting anyone who uses them at risk as security patches are no longer announced.

Best advice is to update your browser as soon as you can. If you don't know what versions you are running you can go here : What browser am I using? If that tells you that you are using IE6 or 7 then you need to upgrade.